ET:QW Competition 1.0 (Beta)

29.02.2008 : 13:58
"With the legalese behind us, the Enemy Territory: Quake Wars Competition Mod Beta is here at last. If you're hunting for more information, you can read more about it last night's dev blog update. Please note that this is an unsupported Beta release you're installing at your own risk. Furthermore, the Mod only works with ET:QW 1.4 and not the 1.5 Beta. When all is said and done, don't forget to post your Competition Mod feedback in this freshly hatched forum."


--> ET:QW Competition 1.0 (Beta)
Steve "badman" Hessel via eMail